A little unsure.

Post new topic Reply to topic
Woodles
Active Member
Active Member
Joined: 11 Mar 2010
Posts: 135
Reply with quote Back to top
Posted: Thu May 03, 2012 1:09 am 
Post subject: A little unsure.
Wouldn't class this post-natal health as my LO is almost 2 now but couldn't figure where else to pop it. Anyway, i had an implant put in a little over a month ago after having a termination for an ectopic pregnancy due to health concerns. The implant was put in the day my bleeding stopped about 2 weeks after i came out of hospital, i had a period a week after having it put in, all was normal for me though i didn't suffer from any cramps (yipee!). But now i seem to be constantly spotting, (tmi incoming) it's not fresh red, more brown, i have no pain or discomfort. I plan on heading to the doctors by Monday if it hasn't stopped before then (so long because i feel fine).
Dr said i was fine when i had my check-up after leaving the hospital, could an infection have popped up so late? I informed myself as much as i could with the information i was given on different contraception when i chose the implant but frankly i've never used any before so i'm unsure if i should be worried.
_________________
steph181
AskBaby Legend
AskBaby Legend
Joined: 27 Jan 2009
Posts: 6036
Reply with quote Back to top
Posted: Sun May 06, 2012 4:07 pm 
Post subject:
it could be a side effect of the implant, not sure as iv never had it. but i did have problems with spotting on the mini pill, not constant, but ever other week (only had a period ever other month) then my period would last 10 days only 3-4 were bleeding.

the doctors usually like you to try something for 3-6 months to get into your system, so i would see how it goes and if no better in a couple of months then maybe look at something else?
_________________


Display posts from previous:   
Post new topic   Reply to topic    AskBaby Talk -> Postnatal Health All times are GMT
Page 1 of 1

 
Jump to:  

Community

Popular